Start a new topic

Formatting issues when exporting to Excel

If I format a number with the comma separator and then export it to excel, Excel sees any number with the comma as text. Eg, 1000 shows as a number, but 1,000 shows as text. I have tested this on several versions of Excel and it is always the same issue. The entire point of being able to export to Excel is that it shows correctly and then if users need to do anything with the data, Excel can work as normal, but in this case, the only way I can format it as 1,000 and then have a user utilise it in Excel is to get them to multiply the column by 1.

The other option is that I do not format the number fields with a comma and then Excel always sees it as a number, but it means if a user wants to see it as 1,000 they again need to format the column in Excel to be comma separated.

1 Comment

In case of Excel, even if you will import data from different locations in which the numbers contains commas, excel considers it as text instead of numeric. This is built-in feature of excel and ElegantJ BI cannot modify the default behavior of it. Usually, we perform all operations on a report before marking it as ready to be a scheduled export, and once exported the report is only used for read only purposes. We suggest you export your reports without a comma separator for numbers in case you have any requirement of performing any actions on it after the report is being exported.

Login to post a comment